Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2026 - 23:00 CEST
Scheduled
We will perform scheduled upgrades to redundant platform components in the night of 2-3 April 2026, between 23:00–04:00. During this maintenance window, customers may experience brief minor service hiccups. We do not expect any major impact.
Thank you for your understanding.
Kind regards,
Remco Eijssen CloudSuite Support
Posted Mar 31, 2026 - 10:03 CEST
This scheduled maintenance affected: CloudSuite API, CloudSuite Ordering Service, and CloudSuite Discovery Service.