Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2026 - 23:00 CEST
Scheduled
We would like to inform you about upcoming scheduled maintenance of our servers.
In order to keep our environments secure our servers will receive extended maintenance. This window has been divided in two batches, with maintenance of the second batch of servers taking place in the night of 2-3 of July between 23:00 and 02:00. Expected downtime is around 1 hour per server.
Posted Jun 25, 2026 - 11:27 CEST
This scheduled maintenance affected: CloudSuite Platform.