The issue has been resolved. Customers who experienced problems as a result of this outage will receive further information later this week regarding the cause and the measures we are taking.
Posted Apr 07, 2026 - 16:09 CEST
Monitoring
The issues have been resolved and the platform is fully operational again. We will further analyse the outage and report our findings.
Posted Apr 07, 2026 - 13:53 CEST
Investigating
We are experiencing an outage on our platform. Engineers are currently investigating the issue. Customers are not able to open the PDP's